sexta-feira, fevereiro 08, 2013

JVM terminated. Exit code=160

Ok, I've got a new powefull T430 at my work: 8Gb memory and i5 (4 2.6Ghz cores) - very nice.

So, this was time for me to install a new Java Development environment. One of the good things you have by working for a software company is that you have access to all of its goodies. In my case, I've access to Rational and Websphere software.

In my current project we are using Rational Team Concert (RTC) 4.0 and as this version supports 64bits, I decided to give a try on the Rational Application Developer 8.5.1 64bits as well.

Yes, I'm running Linux at work - thank you very much.

All the install went well, downloaded the code I'm working on, but then suddently, when I tried to check-in a few changes, bazinga! JVM terminated. Exit code=160.

After some research (google as usual is your friend) I've found some related problems with XUL version, according to this IBM support post.

On my old setup (RAD 8.0) I had to apply that kind of fix, but instead I used this setup:
-Dorg.eclipse.swt.browser.UseWebKitGTK=true
in my eclipse.ini file.

So, I decided to try that fix here too. Done. Issue fixed.

4 comentários:

Fernanda morais oliveira disse...

https://www.facebook.com/photo.php?fbid=564984363526560&set=a.560358480655815.1073741825.535517259806604&type=1&theater

karthick udayakumar disse...

Thanks. It did resolve the problem.

Stuck disse...

Thanks Isaque, I change the eclipse.ini as you recommended to use the internal browser and that solve my problem too.

Piyush Chordia disse...

I tried this and worked for me too. I use RAD 9.x with RTC 4.x integrated. Posted the problem and solution here:

http://www.cubicrace.com/2015/01/rad-eclipse-crash-exit-code-160.html